Your Site Clix Web Editor Help
  Click the required heading for the help that you require
 
  Close Window

  Table of Contents
 
  Logging In
  File Manager
  Changing Into a Folder
  Creating a New Folder
  Creating a New File
  Uploading a File
  Viewing a File
  Editing a File
  The WYSIWYG Editor and commands
  Image Manager
  Renaming a File or Folder
  Deleting a File or Folder
  Logging Out

 
 
Logging In
 
  Table of Contents

  
 
  To Login, simply enter your username and password and click the login button. If you are having problems logging in, check that your CAPS-LOCK key is NOT on and that you are entering the correct username and password.

 
File Manager
 
  Table of Contents

  
 
  The File Manager is where you can see your web-files and web-folders

You will see the size and the date last modified shown for each file and folder.

You can perform general maintenance on your site from the File Manager - upload, create, view, rename and delete files and rename, delete and create folders.

All folders are represented with the folder icon and files with the file icon .

The Current Working Directory, located directly above the Editable Content, will refect at all times your current location in the file system. (The current folder you are in)

 
Changing Into a Folder
 
  Table of Contents

  
 
  To change into a folder, select the desired folder and click on the folder's underlined name.

Current Working Directory (located just on top of your folder and file listing) will change to reflect your current folder.

If you are allowed to go back up a folder, you will see a '[ Up One Level ]' link. Select this link to go back up a folder.

 
Creating a new Folder
 
  Table of Contents

  
 
  To create a new folder, click the 'Create Folder' button at the bottom of the File Manager.

This will take you to another screen that prompts for a name for the new folder.

Enter the name you desire and click 'OK', or click 'Cancel' to go back to the File Manager.

Valid folder names consist of alphanumeric characters (a-z, A-Z 0-9), the underscore '_' or a dash '-'.

A valid folder name can also have a single optional dot in the name '.'.

 
Creating a new File
 
  Table of Contents

  
 
  To create a new file, click the 'Create File' button at the bottom of the File Manager..

This will take you to another screen that has a drop-down menu of templates you can use on a file.

Once you have selected a template, enter a name for the new file.

Valid file names consist of alphanumeric characters (a-z, A-Z 0-9), the underscore '_' or a dash '-'.

A valid file name must have a single dot '.' and be followed by an extension.

To preview the template selected, click on the 'Preview' button.

To create the file once you have entered the new file name, click 'OK'. Click 'Cancel' to go back to the File Manager.

 
Uploading a File
 
  Table of Contents

  
 
  To upload a file, click the 'Upload File' button at the bottom of the File Manager.

This will take you to another screen that requires a file to upload.

Click the 'Browse' button to open a 'Choose File' box that allows you to select a local file to upload.

Once the file has been selected, click 'OK' to begin uploading the file, or click 'Cancel' to be taken back to the File Manager.

Uploads may take a minute or two depending on the speed of your Internet connection.

 
Viewing a file
 
  Table of Contents

  
 
  To view a file, select the desired file and click on the 'View' link. The file will be shown in a pop-up window.

Close the window to return to the File Manager.

 
Editing a file
 
  Table of Contents

  
 
  To edit a file, select the desired file and click on the 'Edit' link.

You will be taken to the WYSIWYG Editor screen.

A full description of WYSIWYG Editor commands can be found here.

 
The WYSIWYG Editor and commands
 
  Table of Contents

  
 
 
Save
  To save changes you have made to a file, click the 'Save' icon. The file will be saved and you will be taken back to the File Manager.
Cancel without Saving
  To cancel changes without saving, click the 'Cancel Without Saving' icon. A dialog box will appear, asking for confirmation. Click the 'OK' button to cancel without saving changes, or the 'Cancel' button to go back to the editor.
Cut (Ctrl+X)
  To cut a portion of the document, highlight the desired potion and click the 'Cut' icon (keyboard shortcut - CTRL+X).
Copy (Ctrl+C)
  To copy a portion of the document, highlight the desired potion and click the 'Copy' icon (keyboard shortcut - CTRL+C).
Paste (Ctrl+V)
  To paste a portion that has already been cut (or copied), click where you want to place the desired portion on the page and click the 'Paste' icon (keyboard shortcut - CTRL+V).
Undo (Ctrl+Z)
  To undo the last change, click the 'Undo' icon (keyboard shortcut - CTRL+Z). Each consecutive click will undo the previous change to the document.
Redo (Ctrl+Y)
  To redo the last change, click the 'Redo' icon (keyboard shortcut - CTRL+Y). Each consecutive click will repeat the last change to the document.
Bold (Ctrl+B)
  To bold text, select the desired portion of text and click the 'Bold' icon (keyboard shortcut - CTRL+B). Each consecutive click will toggle this function on and off.
Underline (Ctrl+U)
  To underline text, select the desired portion of text and click the 'Underline' icon (keyboard shortcut - CTRL+U). Each consecutive click will toggle this function on and off.
Italic (Ctrl+I)
  To convert text to italic, select the desired portion of text and click the 'Italic' icon (keyboard shortcut - CTRL+I). Each consecutive click will toggle this function on and off.
Insert Number List
  To start a numbered text list, click the 'Insert Numbered List' icon. If text has already been selected, the selection will be converted to a numbered list. Each consecutive click will toggle this function on and off.
Insert Bullet List
  To start a bullet text list, click the 'Insert Bullet List' icon. If text has already been selected, the selection will be converted to a bullet list. Each consecutive click will toggle this function on and off.
Decrease Indent
  To decrease indent of a paragraph, click the 'Decrease Indent' icon. Each consecutive click will move text further to the left.
Increase Indent
  To increase indent of a paragraph, click the 'Increase Indent' icon. Each consecutive click will move text further to the right.
Align Left
  To align to the left, make a selection in the document and click the 'Align Left' icon.
Align Center
  To align to the center, make a selection in the document and click the 'Align Center' icon.
Align Right
  To align to the right, make a selection in the document and click the 'Align Right' icon.
Insert Horizontal Line
  To insert a horizontal line, select the location to insert the line and click the 'Insert Horizontal Line' icon.
Create / Modify HyperLink
  To create a hyperlink, select text/image to create the link on, then click the 'Create / Modify HyperLink' icon. A HyperLink window will appear, split into two sections. The top section ('Link Information') will have existing link information, if the object you selected already had a link. You can also type the full URL of the page you want to link to in the URL text box. You can also enter the target window information (optional) and an anchor name (if linking to an anchor - optional).

The bottom section contains a cut-down version of the 'File Manager'. You can use this to navigate through your site's files and folders. When you have found the file you want to link to, click the 'Get Link Location' link next to that page. The information will be automatically updated in the 'Link Information' portion of the page.

When finished, click the 'Insert Link' button to insert the HyperLink you just created, or click 'Remove Link' to remove an existing link. Clicking 'Cancel' will close the window and take you back to the editor.

To modify an existing hyperlink, select the link and click on the 'Create / Modify HyperLink' icon. The HyperLink window will appear. Make your changes and select the 'Insert Link' button. Select the remove link to remove an existing link.

Insert / Modify Anchor
  To insert an anchor, select a desired spot on the web page you are editing and click the 'Insert / Modify Anchor' icon. In the dialogue box, type the name for the anchor.

When finished, click the 'Insert Anchor' button to insert the anchor, or 'Cancel' to close the box.

To modify an anchor select the Anchor (displayed as small yellow box when Guidelines are switched on) and click the 'Insert / Modify Anchor' icon. Make your changes and hit the 'Modify Anchor' button or click 'Cancel' to close the window.
Create Email Link
  To create an email link, select text or an image on the web page you are editing where you would like the link to appear. Click the 'Create Email Link' icon. In the dialogue box, type the email address for the link and the subject of the email.

When finished, click the 'Insert Link' button to insert the email link, or 'Cancel' to close the box.
Insert / Modify Image
  This will open the Image Manager. Click here for more help on the image manager.
Insert Form
  To insert a form, select desired position then click the 'Insert Form' icon.

A new window will pop-up with the following fields: Name - name of form; Action - location of script that processes the form and Method - post, get or none.

Fill in form details or leave blank for a blank form.

When finished, click the 'Insert Form' button to insert form, or click 'Cancel' to go back to the editor.
Modify Form Properties
  To modify form properties, click anywhere inside the form to modify, then click the 'Modify Form Properties' icon.

A pop-up window will appear with the form's properties.

Click the 'Modify Form Properties' button to save your changes, or click 'Cancel' to go back to the editor. Note: this function will not work if a form has not been selected.
Insert / Modify Text Field
  To insert a text field, select desired position then click the 'Insert/Modify Text Field' icon.

A pop-up window will appear with the following attributes: Name - name of text field; Character width - the width of the text field, in characters; Type - type of text field (Text or Password); Initial value - initial text in field and Maximum characters - maximum number of characters allowed.

Set the attributes then click the 'Insert Text Field' button to insert text field, or click 'Cancel' to go back to the editor.

To modify a text field's properties, select desired text field and click the 'Insert/Modify Text Field' icon.

A pop-up window will appear with the text field's attributes.

Modify any attributes desired, then click the 'Modify Text Field' button to save changes, or click 'Cancel' to go back to the editor.
Insert / Modify Text Area
  To insert a text area, select desired position then click the 'Insert/Modify Text Area' icon

A pop-up window will appear with the following attributes: Name - name of text area; Character width - the width of the text area, in characters; Initial value - initial text in area and Lines - number of lines allowed in the text area.

Set the attributes then click the 'Insert Text Field' button to insert the text area, or click 'Cancel' to go back to the editor.

To modify a text area's properties, select desired text area and click the 'Insert/Modify Text Area' icon.

A pop-up window will appear with the text area's attributes.

Modify any attributes desired, then click 'Modify Text Area' button to save changes, or click 'Cancel' to go back to the editor.
Insert / Modify Hidden Area
  To insert a hidden field, select desired position then click the 'Insert/Modify Hidden Field' icon.

A pop-up window will appear with the following attributes: Name - name of hidden field and Initial value - initial value of hidden field.

Set the attributes then click the 'Insert Hidden Field' button to insert the hidden field, or click 'Cancel' to go back to the editor.

To modify a hidden field's properties, select desired hidden field and click the 'Insert/Modify Hidden Field' icon.

A pop-up window will appear with the hidden field's attributes.

Modify any attributes desired, then click 'Modify Hidden Field' button to save changes or click 'Cancel' to go back to the editor.
Insert / Modify Button
  To insert a button, select desired position then click the 'Insert/Modify Button' icon.

A pop-up window will appear with the following attributes: Name - name of text area; Type - type of button (Submit, Reset or Button) and Initial value - initial text on the button.

Set the attributes then click 'Insert Button' to insert button, or click 'Cancel' to go back to the editor.

To modify a button's properties, select desired button and click the 'Insert/Modify Button' icon.

A pop-up window will appear with the button's attributes.

Modify any attributes desired, then click 'Modify Hidden Field' button to save changes or click 'Cancel' to go back to the editor.
Insert / Modify Checkbox
  To insert a checkbox, select desired position then click the 'Insert/Modify Checkbox' icon.

A pop-up window will appear with the following attributes: Name - name of checkbox; Initial state - checked or unchecked and Initial value - value of checkbox.

Set the attributes then click the 'Insert Checkbox' button to insert the checkbox, or click 'Cancel' to go back to the editor.

To modify a checkbox' properties, select desired checkbox and click the 'Insert/Modify Checkbox' icon.

A pop-up window will appear with the checkbox' attributes.

Modify any attributes desired, then click 'Modify Checkbox' button to save changes or click 'Cancel' to go back to the editor.
Insert / Modify Radio button
  To insert a radio button, select desired position then click the 'Insert/Modify Radio Button' icon.

A pop-up window will appear with the following attributes: Name - name of radio button; Initial state - checked or unchecked and Initial value - value of radio button.

Set the attributes then click 'Insert Radio Button' to insert the radio button, or click 'Cancel' to go back to the editor.

To modify a checkbox' properties, select desired checkbox and click the 'Insert/Modify Radio Button' icon.

A pop-up window will appear with the checkbox' attributes.

Modify any attributes desired, then click 'Modify Radio Button' button to save changes or click 'Cancel' to go back to the editor.
Font
  To change the font of text, select the desired portion of text and click the 'Font' drop-down menu.

Select the desired font (choose from Default - Times New Roman, Arial, Verdana, Tahoma, Courier New or Georgia).
Font Size
  To change the size of text, select the desired portion of text and click the 'Size' drop-down menu.

Select the desired size (text size 1-7).
Font Color
  To change the colour of text, select the desired portion of text and click the 'Colour' drop-down menu.

Select the desired colour from the large selection in the drop-down menu.
Format
  To change the format of text, select the desired portion of text and click the 'Format' drop-down menu.

Select the desired format (choose from Normal, Superscript, Subscript and H1-H6).
Style
  To change the style of text, images, form objects, tables, table cells etc select the desired element and click the 'Style' drop-down menu, which will display all styles defined in the style-sheet.

Select the desired style from the menu.

Note: this function will not work if there is no style-sheet applied to the page.
Insert Table
  To insert a table, select the desired location, then click the 'Insert Table' icon.

A new window will pop-up with the following fields: Rows - number of rows in table; Columns - number of columns in table; Width - width of table; BgColour - background colour of table; Cell Padding - padding around cells; Cell Spacing - spacing between cells and Border - border around cells.

Fill in table details then click the 'Insert Table' button to insert table, or click 'Cancel' to go back to the editor.
Modify Table Properties
  To modify table properties, select a table or click anywhere inside the table to modify, then click the 'Modify Table Properties' icon.

A pop-up window will appear with the table's properties. Click the 'Modify Table Properties' button to save your changes, or click 'Cancel' to go back to the editor.

Note: this function will not work if a table has not been selected.
Modify Cell Properties
  To modify cell properties, click inside the cell to modify, then click the 'Modify Cell Properties' icon.

A pop-up window will appear with the cells' properties.

Click the 'Modify Form Properties' button to save your changes, or click 'Cancel' to go back to the editor.

Note: this function will not work if a cell has not been selected and does not work across multiple cells.
Insert Row Above
  To insert row above, click inside cell above which to insert a row, then click the 'Insert Row Above' icon.

Each consecutive click will insert another row above the selected cell.

Note: this function will not work if a cell has not been selected.
Insert Row Below
  To insert row below, click inside cell below which to insert a row, then click the 'Insert Row Below' icon.

Each consecutive click will insert another row below the selected cell.

Note: this function will not work if a cell has not been selected.
Delete Row
  To delete a row, click inside cell which is in the row to be deleted, then click the 'Delete Row' icon.

Note: this function will not work if a cell has not been selected.
Insert Column After
  To insert column after, click inside cell after which to insert a column, then click the 'Insert Column After' icon.

Each consecutive click will insert another column after the selected cell.

Note: this function will not work if a cell has not been selected.
Insert Column Before
  To insert column before, click inside cell before which to insert a column, then click the 'Insert Column After' icon.

Each consecutive click will insert another column before the selected cell.

Note: this function will not work if a cell has not been selected.
Delete Column
  To delete a column, click inside cell which is in the column to be deleted, then click the 'Delete Column' icon.

Note: this function will not work if a cell has not been selected.
Increase Column Span
  To insert column span, click inside cell who's span is to be increased, then click the 'Increase Column Span' icon.

Each consecutive click will further increase the column span of the selected cell.

Note: this function will not work if a cell has not been selected.
Decrease Column Span
  To decrease column span, click inside cell who's span is to be decreased, then click the 'Decrease Column Span' icon.

Each consecutive click will further decrease the column span of the selected cell. Note: this function will not work if a cell has not been selected.
Insert Special Characters
  To insert a special character, click the 'Insert Special Character' icon.

A pop-up window will appear with a list of special characters.

Click the icon of the character to insert, then click the 'Insert Character' button to insert, or click 'Cancel' to go back to the editor.
Modify Page Properties
  To modify page properties, click the 'Modify Page Properties' icon.

A pop-up window will appear with page attributes: Page Title - title of page; Description - description of page; Background Image - The URL of the image curently set as the page background image; Keywords - keywords page is to be recognized by; Background Colour - the background colour of page; Text Colour - colour of text in page and Link Colour - the colour of links in page.

When finished modifying, click the 'Modify Page' button to save changes, or click 'Cancel' to go back to the editor.
Clean Up HTML Code
  To clean HTML code, click the 'Clean HTML Code' icon.

This will remove any empty span and paragraph tags, all xml tags, all tags that have a colon in the tag name (i.e. <tag:with:colon>) and remove style and class attributes.

This is useful when copying and pasting from Microsoft Word documents to remove unnecessary HTML code.
Switch Editing Mode (Text or WYSIWYG)
  To switch between editing modes, click the 'Switch Editing Mode (Text or WYSIWYG)' icon.

This will toggle between the editing modes (Text - showing all the HTML or WYSIWYG - showing the content of the page).

Note that the status bar (at the bottom of the window) will reflect the editing mode currently in use.

This is recommended for advanced users only.
Show / Hide Guidelines
  To show or hide guidelines, click the 'Show/Hide Guidelines' icon.

This will toggle between displaying table and form guidelines and not showing any guidelines at all.

Tables and cells will have a broken grey line around them, forms will have a broken red line around them, while hidden fields will be a pink square when showing guidelines.

Note that the status bar (at the bottom of the window) will reflect the guidelines mode currently in use.
Show Preview
  To show a preview of the page being edited, click the 'Show Preview' icon.

This will bring up a pop-up window previewing the page being edited.

This is useful in previewing a file to see how it will look exactly in your browser, before changes are saved.

 
Image Manager
 
  Table of Contents

  
 
 

The Image Manager is where you can see your image files and image folders.

You will see the size and the date last accessed shown for folder.

Each image will be previewed as a thumbnail.

You can perform general maintenance on your images from the Image Manager - insert, set as background, upload, view, rename and delete images and rename, delete and create folders.

All folders are represented with the folder icon and the files with their own thumbnail.

The Current Working Directory, located directly above the Images, will refect at all times your current location in the file system, relative to your document root.

Viewing an Image
To view an image, select the desired image and click on the 'View' link.

The image will be shown in a pop-up window in it's full size.
Close the window to return to the Image Manager.

Inserting an Image
To insert an image, click the 'Insert' link in the image browser next to the image to be inserted.

Set background Image
To set an image as a background image, click the 'Backgd' link in the image browser next to the image to be set.

The image will be set as the current page background image.

Renaming an Image or a Folder
To rename, select the desired image or folder and click on the 'Rename' link.

This will take you to another screen that requires a new name for the image/folder.

Enter a valid name and click 'OK' to rename, or click 'Cancel' to be taken back to the Image Manager.

Valid image names consist of alphanumeric characters (a-z, A-Z 0-9), the underscore '_' or a dash '-'.

A valid image name must have a single dot '.' and be followed by an extension.

Valid image extensions are specified in the configuration file.

Deleting an Image or folder
To delete, select the desired image or folder and click on the 'Delete' link.

You will be prompted for confirmation of the deletion.

If you are sure you wish to delete the selected image/folder, click 'OK'.

Clicking on 'Cancel' will take you back to the Image Manager.

Uploading an Image
To upload an image, click the 'Upload Image' button at the bottom of the Image Browser.

This will take you to another screen that prompts for an image to upload.

Click the 'Browse' button to open a 'Choose File' box that allows you to select a local image to upload.

Once the file has been selected, click 'OK' to begin uploading the file, or click 'Cancel' to be taken back to the Image Manager

Upon sucessful upload of the image, you will be taken back to the Image Manager.


Changing Into a Folder
To change into a folder, select the desired folder and click on the folder's underlined name.

Current Working Directory (located just on top of your folder and file listing) will change to reflect your current folder.

If you are allowed to go back up a folder, you will see a '[ Up One Level ]' link. Select this link to go back up a folder.

Creating a New Folder
To create a new folder, click the 'Create Folder' button at the bottom of the Image Browser.

This will take you to another screen that prompts for a name for the new folder.

Enter the name you desire and click 'OK', or click 'Cancel' to go back to the Image Browser.

Valid folder names consist of alphanumeric characters (a-z, A-Z 0-9), the underscore '_' or a dash '-'.

A valid folder name can also have a single optional dot in the name '.'.


 
Renaming a File or Folder
 
  Table of Contents

  
 
  To rename, locate the desired file / folder and click on the 'Rename' link.

This will take you to another screen that requires a new name for the file / folder.

Enter a valid name and click 'OK' to rename, or click 'Cancel' to be taken back to the File Manager.

 
Deleting a File or Folder
 
  Table of Contents

  
 
  To delete a file or folder, locate the desired file or folder and click on the 'Delete' link.

You will be prompted for confirmation of the deletion.

If you are sure you wish to delete the selected file/folder, click 'OK'. Clicking on 'Cancel' will take you back to the File Manager.

 
Logging Out
 
  Table of Contents

  
 
  To Logout, click the 'Logout' link from the File Manager. It is always good practice to log out after you have completed your work.